Lightning Outage

Incident Report for AccuWeather for Business

Resolved

This incident has been resolved.
Posted Oct 17, 2025 - 13:35 EDT

Update

We are continuing to investigate this issue.
Posted Oct 17, 2025 - 13:35 EDT

Update

We are continuing to investigate this issue.
Posted Oct 17, 2025 - 13:25 EDT

Investigating

Data outage related to lightning data is being investigated.
Posted Oct 17, 2025 - 13:14 EDT
This incident affected: GIS Services and Portal Website & SkyGuard Mobile Application.